{"_id":"58aad9df8f862f250076fa51","project":"54aa7f773b56130b0056c86e","parentDoc":null,"__v":0,"category":{"_id":"58aad9dd8f862f250076f9f7","version":"58aad9dd8f862f250076f9f4","project":"54aa7f773b56130b0056c86e","__v":0,"sync":{"url":"","isSync":false},"reference":false,"createdAt":"2015-01-05T12:43:51.897Z","from_sync":false,"order":3,"slug":"ios-sdk","title":"iOS SDK"},"user":"54aa7f3f9bb00c0b00cb899b","version":{"_id":"58aad9dd8f862f250076f9f4","project":"54aa7f773b56130b0056c86e","__v":2,"createdAt":"2017-02-20T11:58:21.765Z","releaseDate":"2017-02-20T11:58:21.765Z","categories":["58aad9dd8f862f250076f9f5","58aad9dd8f862f250076f9f6","58aad9dd8f862f250076f9f7","58aad9dd8f862f250076f9f8","58aad9dd8f862f250076f9f9","58aad9dd8f862f250076f9fa","58aad9dd8f862f250076f9fb","58ac26b3d460ce2500185d26"],"is_deprecated":false,"is_hidden":false,"is_beta":false,"is_stable":false,"codename":"Locate","version_clean":"6.0.0","version":"6.0"},"updates":[],"next":{"pages":[],"description":""},"createdAt":"2015-01-05T12:52:49.442Z","link_external":false,"link_url":"","githubsync":"","sync_unique":"","hidden":false,"api":{"results":{"codes":[]},"settings":"","auth":"required","params":[],"url":""},"isReference":false,"order":2,"body":"[block:api-header]\n{\n  \"type\": \"basic\",\n  \"title\": \"Step 1: Add Pulsate Files to Project\"\n}\n[/block]\n**1. **Download Pulsate SDK from the repository through Git:\n[block:code]\n{\n  \"codes\": [\n    {\n      \"code\": \"git clone https://github.com/PulsateHQ/pulsate-ios-sdk\",\n      \"language\": \"shell\"\n    }\n  ]\n}\n[/block]\n\n[block:callout]\n{\n  \"type\": \"info\",\n  \"body\": \"You can do that manually by going to the[ Pulsate Github repository](https://github.com/PulsateHQ/pulsate-ios-sdk) and pressing *\\\"Download ZIP\\\"*\"\n}\n[/block]\nThe Pulsate SDK package contains:\n\n• **PULPulsate.framework** - the Pulsate framework compiled for arm7, arm64 and simulator.\n• **PULPulsateBasic.bundle** - the Pulsate bundle containing all image assets and CoreData schema, used by Pulsate SDK\n\n \n**2. **You can either drag and drop these files into your project, or select a group in XCode Project Navigator and go to *File* -> *Add Files to...* and select the folder with the Pulsate framework and bundle.\n[block:callout]\n{\n  \"type\": \"info\",\n  \"body\": \"Make sure that 'Copy items into destination group’s folder' checkbox is set.\"\n}\n[/block]\n\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/qT7yahIXTnmZEdttKQdH_Tutorial2.png\",\n        \"Tutorial2.png\",\n        \"583\",\n        \"241\",\n        \"#a44e25\",\n        \"\"\n      ]\n    }\n  ]\n}\n[/block]\n\n[block:api-header]\n{\n  \"type\": \"basic\",\n  \"title\": \"Step 2: Add Required Frameworks\"\n}\n[/block]\n**Please add all of the frameworks listed below to your project:**\n\n• CoreLocation.framework\n• libz.dylib (libz.tbd in Xcode 7)\n• CoreData.framework\n• SystemConfiguration.framework\n• CoreBluetooth.framework\n[block:api-header]\n{\n  \"type\": \"basic\"\n}\n[/block]\n\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/SH4MWAWYTuc4pp5Bde6b_Screen%20Shot%202015-06-11%20at%2014.03.38.png\",\n        \"Screen Shot 2015-06-11 at 14.03.38.png\",\n        \"924\",\n        \"428\",\n        \"#cb9836\",\n        \"\"\n      ]\n    }\n  ]\n}\n[/block]\n\n[block:api-header]\n{\n  \"type\": \"basic\",\n  \"title\": \"Step 3: Add Needed Linker Flags\"\n}\n[/block]\nYou need to add **-ObjC** linker flag to project linker configuration. To do this, go to *Build Settings* tab of project settings, then to the *Linking* section and the flag to *Other Linker Flags* row, they are needed to load Pulsate (or any other library) category files properly.\n[block:api-header]\n{\n  \"type\": \"basic\",\n  \"title\": \"Step 4 (Optional) : Using Swift\"\n}\n[/block]\nIf you're using Swift, you need to create a [bridging header](https://developer.apple.com/library/ios/documentation/Swift/Conceptual/BuildingCocoaApps/MixandMatch.html) to use the Pulsate SDK.","excerpt":"","slug":"manually-installing-the-pulsate-sdk","type":"basic","title":"Manually Installing the Locate SDK"}

Manually Installing the Locate SDK


[block:api-header] { "type": "basic", "title": "Step 1: Add Pulsate Files to Project" } [/block] **1. **Download Pulsate SDK from the repository through Git: [block:code] { "codes": [ { "code": "git clone https://github.com/PulsateHQ/pulsate-ios-sdk", "language": "shell" } ] } [/block] [block:callout] { "type": "info", "body": "You can do that manually by going to the[ Pulsate Github repository](https://github.com/PulsateHQ/pulsate-ios-sdk) and pressing *\"Download ZIP\"*" } [/block] The Pulsate SDK package contains: • **PULPulsate.framework** - the Pulsate framework compiled for arm7, arm64 and simulator. • **PULPulsateBasic.bundle** - the Pulsate bundle containing all image assets and CoreData schema, used by Pulsate SDK **2. **You can either drag and drop these files into your project, or select a group in XCode Project Navigator and go to *File* -> *Add Files to...* and select the folder with the Pulsate framework and bundle. [block:callout] { "type": "info", "body": "Make sure that 'Copy items into destination group’s folder' checkbox is set." } [/block] [block:image] { "images": [ { "image": [ "https://files.readme.io/qT7yahIXTnmZEdttKQdH_Tutorial2.png", "Tutorial2.png", "583", "241", "#a44e25", "" ] } ] } [/block] [block:api-header] { "type": "basic", "title": "Step 2: Add Required Frameworks" } [/block] **Please add all of the frameworks listed below to your project:** • CoreLocation.framework • libz.dylib (libz.tbd in Xcode 7) • CoreData.framework • SystemConfiguration.framework • CoreBluetooth.framework [block:api-header] { "type": "basic" } [/block] [block:image] { "images": [ { "image": [ "https://files.readme.io/SH4MWAWYTuc4pp5Bde6b_Screen%20Shot%202015-06-11%20at%2014.03.38.png", "Screen Shot 2015-06-11 at 14.03.38.png", "924", "428", "#cb9836", "" ] } ] } [/block] [block:api-header] { "type": "basic", "title": "Step 3: Add Needed Linker Flags" } [/block] You need to add **-ObjC** linker flag to project linker configuration. To do this, go to *Build Settings* tab of project settings, then to the *Linking* section and the flag to *Other Linker Flags* row, they are needed to load Pulsate (or any other library) category files properly. [block:api-header] { "type": "basic", "title": "Step 4 (Optional) : Using Swift" } [/block] If you're using Swift, you need to create a [bridging header](https://developer.apple.com/library/ios/documentation/Swift/Conceptual/BuildingCocoaApps/MixandMatch.html) to use the Pulsate SDK.